Jump to content

Austin Edwards

Members
  • Content Count

    7
  • Joined

  • Last visited

About Austin Edwards

  • Rank
    TT Newbie

Profile Information

  • Location
    USA
  1. Just got my bike back from the dealer they checked the fuel pressure and it was low so they checked the pump and found it to be bad and replaced it and now the bike is running great! Thanks for the help!
  2. Hey guys just got it back from the dealer they checked the fuel pressure and it was low so they found out it had a bad fuel pump. They put the new pump in today and now it’s running great! Thanks for the help guys!
  3. I’ll update you guys when I find out what the dealer has to say! Thanks for the input guys! Thinking it might be a fuel pump as well.
  4. I’ll be sure to let them know. I’ll let you know when I get an update. Thanks
  5. I got a 2018 KTM 690 Enduro R with 1200 miles on it and the bike is stock other than I have put on a wings exhaust 3 months ago and the bike has run fine with it. But go to ride today and the bike at idle during start it just shuts off and it won’t run unless you give it throttle. Sounds like a fueling issue. Also when riding the bike bogs down anytime you give it some throttle. Just looking to see if anyone can expand on this. Brought it to the dealer today and they’re going to take a look at it.
  6. Evan thanks for the posts! My 2018 ktm 690 Enduro R has 1200 miles on it and it’s having the same issue during start up. Also when riding it bogs down as well. The bike is stock other than I have put on a wings exhaust a few months ago and it ran fine with it on. Just now starting to get idling problems. It’s under warranty so I brought it in to the dealer and they’re going to look at it. After seeing your video I might have the same fuel inline filter leak as well. I’ll be sure to let you know.
×
×
  • Create New...