bekroors

Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

10 Good

About bekroors

  • Rank
    TT Newbie

Profile Information

  • Location
    California
  1. Motosprtman, thanks for the tip on the oil. 20-50 castrol dino is my best bet? I am planning to ride mostly on desert highways, with 95 to 105 temps, still the best oil? Well if you have been using castrol 20-50 for 30 years with no problems I would assume you have experienced all types of conditions? roadcam, XR650L_Dave, and ghoti, the meaning of NO CLUTCH in my case is : when clutch lever is pulled in I can not shift into 1st or 2nd gear.it grinds into first and stalls, the clutch does not engage to allow for shifting. and remember I said with the cables disconnected, and with my hand pulling on the lever that comes out of the case, the clutch still would not engage! so this to me would mean not a cable problem. So maybe I should just try draining the synthetic oil and use 20-50 castrol like Motosprtman suggested and see what happens? I'm still wondering if the clutch plates need to be replaced because of what the stinking synthetic oil did! does this soundlike the right thing to do? thanks for any help or experience given.
  2. I bought my 94 XR650L a few months ago, the clutch worked fine while on test ride. I desided to restore the bike with some new aftermarket parts and oil change. I bought the moose EZ-pull clutch system and had to slightly modify cables to get it to work. And I changed oil&filter, and put in Mobile 1 MX4T 10-40 4 cycle Fully Synthetic Oil. I don't know what oil was in there before but it was old and dirty. now after starting bike and warm up, NO CLUTCH??? I thought it might be cable so I removed it and tried engaging it were the clutch lever comes out of the case. still NO CLUTCH??? The bike has just under 8000k on it, low for a 94. I am the 3rd owner. any advice for this amateur? do I need a new Clutch kit?