KRAMNOSWAD

Members
  • Content count

    5
  • Joined

  • Last visited

Community Reputation

10 Good

About KRAMNOSWAD

  • Rank
    TT Newbie

Profile Information

  • Location
    United Kingdom
  1. Thanks Will Hope To Try What You Have Said Tomorrow !!!
  2. No Its Cable Operated Clutch ! Cheers For Your Help Mark !
  3. It Was My First Oil Change ,as I Have Only Owned It For For A Month . The Previous Owner Said The Oil Had Been Changed Regularly , But To Be Sure I Thought It Best To Do My Own . I Wish I Had Never Bothered Now !!!! The Bike Is An Electric Start Only Model . Many Thanks For Your Help ! Cheers Mark .
  4. PLEASE COULD SOMEONE GIVE ADVISE AS TO WHY MY CLUTCH WILL NO LONGER WORK AFTER DOING A OIL AND FILTER CHANGE ON MY 2000 MODEL TE 610 , I NOTICED ON MY FIRST 3 MILE JOURNEY TO WORK THAT THE CLUTCH WAS DRAGGING SLIGHTLY THE NEXT DAY IT DID THE SAME ! MY BIKE WAS THEN UNUSED FOR TWO DAYS , BUT WHEN I TRIED TO RIDE IT EVERY TIME I PULLED THE CLUTCH IN TO SELECT FIRST GEAR IT WAS AS IF I HAD NO CLUTCH AT ALL . NO MATTER HOW MUCH I ADJUST IT I STILL CANNOT GUT THE CLUTCH TO WORK THE OIL USED WAS QUALITY PUTOLINE . I JUST CANNOT WORK OUT WHAT MIGHT OF HAPPENED ? DROP OIL , RE FILL , THEN NO CLUTCH !!! IF ANYONE HAS ANY IDEA I WOULD BE MOST GRATEFUL !!! CHEERS MARK !
  5. Could anyone give help with my clutch problem ? I did a oil and filter change on my 2000 model te 610 . But since then my bikes clutch no longer will work , no amount off adjusting will solve the problem . The oil used was top quality putoline .