cumminsgetsome

Members
  • Content count

    48
  • Joined

  • Last visited

Community Reputation

10 Good

About cumminsgetsome

  • Rank
    TT Member

Profile Information

  • Location
    Colorado
  1. You might want to clean your air filter it may be dirty and causing a rich condition
  2. Sounds like maybe the de compression on the cam is not working if the starter can't turn it over?. Is it hard to kick?
  3. diid you lay the bike on its side to do the pump if so gas can run out into your intake and flood the engine and foul the plug. I had a 250 that it happened to me on.
  4. Fouled plug??
  5. Did you lay the bike on its side to do the pump if so carb might have spilled over in the intake and flooded the engine.
  6. I have an 04 and am running 14 /49 gearing. I love it, I put a pro circuit pipe on it and it really boosted the low end. I use my bike for tight single track, and also hill climb with it. It is a monster.
  7. I had the same problem on my 02 when I got it. Pull out the needle seat and there is a o-ring on it that was bad on mine.
  8. There is something definantly wrong. My sons will flat rip.
  9. I think the ignition is a totally seperate from the lighting coil. One should not be able to affect the other. But I may be wrong about this.
  10. Did you use the hot start when you were trying to kick it sometimes mine needs it other times it don't like it?
  11. Yea it has the electric start. I thinink I will go with a new cdi I had a klr 250 and had a cdi fail on it so I am thinking it would be better to go new. I tried to look it up in the tt store but could figure out how to find it? Thanks for your help. Matt
  12. Just bought a 93 klx 650 it has some electrical issues. I cannot find the cdi the kid I bought it from did a jump and the bottom of the battery box broke out. And the inner fender caught on the tire and tore out some electrical that was on the top what all componets sit on top of that I think that is where the cdi was but not sure I cannot find it anywhere else. Thanks for your help
  13. Sounds similar to my 04 except I am running a 168 main. I tried a 48 pilot but it got hard to start so I went back with the 50. I am at 7000 ft. I also tried a 165 main but it runs stronger with the 168.
  14. Sounds like maybe the cam chain is loose? Would be a easy fix if that is what it is.
  15. I have got a clark tank on my wr 250 I would trade the tank and seat for your tank and seat. I think the clark is 3.3 gallon and the seat is in good condition I could send pics?