• Announcements

    • Bryan Bosch

      JUST IN!   04/24/2018

      HOW TO: 4-STROKE PISTON REPLACEMENT DONE RIGHT!

frodaddy57

Members
  • Content count

    19
  • Joined

  • Last visited

Community Reputation

10 Good

About frodaddy57

  • Rank
    TT Newbie

Profile Information

  • Location
    Ontario
  1. Had the same issue with my 02 CR125. Installed the rebuild kit and it was still the same. Turned out to just be air. Be patient with it. I used the rubber end of a screw driver to tap the reservoir with the brake held in. You will see the air bubbles come out, Took a while to get all the air out. Good luck!!
  2. Thanks for the help guys. I'll take a look at it tonight when I get home.
  3. Hi guys, Having a problem with my rear brake. I takes a lot of force on the pedal for the rear wheel to lock. I just purchased and installed a rebuild kit. It didn't solve the problem. There's lots of pad left and I took sand paper to scuff them up. Still the brake is the same. Any ideas? Any help would be greatly appreciated. Thanks guys.
  4. Hey guys thanks for all the help. Sprayed some quickstart into the carb and it fired up for a few seconds. Took the carb apart and cleaned the jets again. Used a fine wire this time and made sure to clean them really well. Re-assembled an Vrrrroooom. Fired right up. Thanks again. Problem solved
  5. Yupper.. It is getting spark. Lots of compression as well.
  6. Tried the drain screw last night. Flowed like Niagara Falls. Took the filter off and it's spotless. I've tinkered with the idle screw and air screw. Don't know what else to try. Any other ideas?
  7. Thanks chickenhauler.. I'll give that a go tonight.
  8. Hey guys, Got an XR70 that won't start. Took the carb apart, cleaned and blew out the jets, Re-assembled. Still won't start. I put a new plug in it. Tried kickin it over a bunch of times. Got it started for a approx 2 seconds then died. Took the plug out and it was bone dry. I don't think it's gettin any gas. I removed the main gas line and turned on the petcock so I know it's flowin out of the tank to the carb. After that point I'm lost. Any ideas? Thanks guys
  9. I too get armpump pretty bad. One thing I find that helps a bit is taking aspirin 10 mins or so before I do a moto. Maybe it's just a mental thing but I find I can do a few more laps after I've taken one or two.
  10. I had an SSR shipped to a Buddies place in the states and just had him drive it over one day. It can be big hassle dealing with Customs, paying taxes, having the bike inspected by Canadian Tire. Too much money.
  11. Yeah.. The brake lever is awesome. I had to carry my bike home when I bent the pegmount cause it locked up the rear brake. Good work.
  12. Those are some sweet mods. I didn't even know about the rear brake hitting the swinger. The footpeg mount looks killer. Here's a pic of the mounts my buddy made with Stainless steel for 15 bucks. I should have taken a picture of them not mounted but oh well. http://i78.photobucket.com/albums/j100/frodaddy57/IMG_20392.jpg
  13. This is how I broke in my SSR pit bike. http://www.mototuneusa.com/break_in_secrets.htm I have no idea if it's the right way to do it but I guess it's worth a read. My bike seems to run good using that method. But definately change your oil like speedo241 said.
  14. A friend of mine purchased a new CR250 from a guy in Kentucky last winter. The guy drove it accrossed the border and told customs that he was going to do some winter riding. The guy drove back to Kentucky an hour later without the bike. No questions were asked. Maybe he just got lucky.. I dunno. If you say you're comming to do some riding I'm sure it wouldn't be a problem.
  15. Use Windows Media player. Under the options, performance tab, video acceleration slider... change it to none. Then hit the print screen button on your keyboard and paste it into paintbrush or photoshop.