• Announcements

    • Bryan Bosch

      JUST IN!   04/24/2018

      HOW TO: 4-STROKE PISTON REPLACEMENT DONE RIGHT!

markbarnett

Members
  • Content count

    12
  • Joined

  • Last visited

Community Reputation

10 Good

About markbarnett

  • Rank
    TT Newbie

Profile Information

  • Location
    Utah
  1. Have you tightened your cam-chain? If it has slop in it, it might be throwing off your timming just a hair. Also check the fitting from your air box to carb. and spark plug gap.
  2. Any idea what causes back-firing and popping during engine braking? Also, my bike is hard to start when cold, I usually have to crack the throttle half way (then I let go) before kicking and it will take upwards of six kicks. Without the throttle blip, it will absolutely not start even with a hundred kicks. I installed a slip on Yoshi TRC silencer and after runnung it a bit the pipe was still a golden color indicating a rich setting, so I dropped the main down 5 mm and leaned the needle jet one notch. I've also tried the fuel air mixture at various settings and that doesn't seem to help. any thoughts or idea's would be appreciated.
  3. I went thru the owners manual a hundred times and could not find how to adjust the cam chain, only how to inspect it and disassemble it. Any help would be appreciated. I've heard it was easy and I know where the adjuster is - just don't know how to go about it. love the bike! love the power! best handling bike I've ever ridden!!
  4. thanks for your help, first, it is a slip on and I am at about 4200 ft. give or take a few feet.
  5. rocky mountain atv sells them go to www.rockymountainatv.com
  6. does anyone know how to tell what date your bike was manufactuered in the vin #?
  7. how do you check teh month in which the bike was manufactured?
  8. find out when the 05 was manufactured, it seems it only affected the early models, before july.
  9. how do you tell when your bike was manufactured? is it in the v.i.n # ?
  10. I have an 05 and put a Yoshi pipe on it, changed the main jet from 165 (stock) to a 170 and now it's not starting worth a #$@*! it will eventually start with about fifteen kicks and about half throttle after afew backfires, any suggestions? I haven't checked the chain tension but figured that would not be it. any help would be appreciated p.s. it has always backfired when engine braking, even when it was running and starting good is this because the air/fuel is to rich?
  11. I have an 05 and put a Yoshi pipe on it, changed the main jet from 165 (stock) to a 170 amd now it's not starting worth a #$@*! any suggestions? I haven't checked the chain tension but figured that would not be it. any help would be appreciated
  12. sorry your having problems, i read an article on the Leo pipe last year and it did say it was a bitch to install. they went on to say that you need to read the instructions very carefully and follow them to a tee even if you are an experienced mechanic---hope that helps! if not call LEo!