Jump to content

mercury7413

Members
  • Content Count

    5
  • Joined

  • Last visited

About mercury7413

  • Rank
    TT Newbie

Profile Information

  • Location
    Colorado
  1. mercury7413

    Rear Brakes (NEED HELP!!!) XR 400

    Well i rebuilt the master cylinder and that did not seem to help at all. I flushed the brakes again just to make sure and that didnt do the trick. Just like before it is grabbing the brakes just not very hard. I guess i will now go to the caliber and clean that up. Any other suggestions?
  2. I just bought a used XR400 and fixed up the noticable things (new clutch cable, fenders, and light kit) However, ive never owned a XR 400, so i was curious to see if there was anything i should know about it (front springs go bad quickly) or anything of that nature. THanks guys.
  3. mercury7413

    Rear Brakes (NEED HELP!!!) XR 400

    Is there something i did, or didnt do to make it go out so quickly? Is there regular maintenance i should be performing to keep these parts in tact. I actually just bought it from a guy in my area, and got a really good deal on it. But i wanted to make sure there were not things i needed to do to it. Thanks again for everyone's responses. I just found this site, and it looks like it is going to be very useful.
  4. I have a 96' XR400 that i can not get the rear brake to work correctly. It is making contact, but you have to practically put all your wait on it to think about properly stopping. I have replaced the pads, and flushed the brake fluid to make sure it wasnt old fluid giving me trouble. Does anyone have any suggestions? Thanks for your help!
  5. mercury7413

    Rear Brake (NEED HELP!!!)

    I have a 96' XR400 that i can not get the rear brake to work correctly. It is making contact, but you have to practically put all your wait on it to think about properly stopping. I have replaced the pads, and flushed the brake fluid to make sure it wasnt old fluid giving me trouble. Does anyone have any suggestions? Thank you so much for your time!
×