Jump to content

ghetto rider

Members
  • Content Count

    77
  • Joined

  • Last visited

About ghetto rider

  • Rank
    TT Member

Profile Information

  • Location
    California
  1. ghetto rider

    poor spark, not running

    S issue.
  2. ghetto rider

    poor spark, not running

    Lack of free time and workspace, I had put the tools away when the new stator fixed all problems. I soon will be working on the other bike and might be buying a new stator for it as well. I will get back with final results.
  3. ghetto rider

    reno nevada area

    I would if I lived there. I just wanted to ask you if you heard of the enduro race out of Virginia City. Not sure when they hold it but that would be a blast.
  4. ghetto rider

    DRZ400S 07 not charging right

    This sounds like a problem I had on my 07 S and it turned out to be the stator. After market stator gave me 14.3V at idle. You can lean the bike over and not lose much oil when you take the case off. But hopefully you find a simple fix:ride: You should actually change oil if the stator needs replacement since I have learned here bad oil will bake on to the stator causing failure.
  5. ghetto rider

    poor spark, not running

    OK OK OK. I now have found what has been the root of my problems. The STATOR! I have been testing everything for a while and found different readings that leads me to believe the stator had a intermittent short that finally failed for good. I got a stator through RMSTATOR and without the "Free Power Mod" I read 14.4V at the battery during idle. This seems like I can put off that peticular mod indefinatly. Thanks for the help Now I need to worry about the stator from my other bike that did not solve my problem a little while ago.
  6. ghetto rider

    JD kit 07drzS. Jetting set up ?

    WOW!!!! I just got back last night from the mountains and that JD kit with Eddie's set up was absolutly perfect. Thank you very much Eddie!!! I now have instant throttle response and more power that pulled me up mountains and over logs and rocks with all of my gear stapped to the back.
  7. ghetto rider

    JD kit 07drzS. Jetting set up ?

    Thank you very much. Can harldy wait for the morning.
  8. ghetto rider

    JD kit 07drzS. Jetting set up ?

    What would Eddie do? I won't PM him, but I would Greatly appreciate his input. I live at sea level and found those settings, but am looking for compromise for 4,000 to 8,000ft elevations for my travels. If I missed this info for my stock bike, can anyone point me to the answer? Thank you!
  9. ghetto rider

    JD kit 07drzS. Jetting set up ?

    I am leaving for the mountains tomorrow morning, so if I don't hear about my jetting set up before tonight, should I still do the 3X3 mod for a stock carb at 4,000 ft to 8,000ft ele.?
  10. ghetto rider

    JD kit 07drzS. Jetting set up ?

    2007 drz 400S. Stock exhaust, stock carb, 3x3 mod (when I change jetting), 4,000ft to 8,000ft elevation. I am going camping on my bike in a day and just received the JD kit and not sure what setup( main and pilot jet, needle and clip, fuel turns) I should be using. (I did search but may have missed it) Thanks!
  11. ghetto rider

    poor spark, not running

    I say that because I couldn't check peak voltage according to the manual saying only check with peak voltage adapter. Anyways I swapped the stator from my running bike which did not solve my problem.
  12. ghetto rider

    poor spark, not running

    2007 drz 400S, 4,500 miles, no engine/carb mods, edge taillight. Ran perfect then idling at signal it sputtered and died. I studied manual and trouble shot everything (except where a peak voltage adapter is called for), swapped spark plugs, carb was clean, air clear, fuel delivered normal, connectors good, battery good, starter good, ignition coil checked out, I think the stator checked out. I did find the bike starts up perfect when I disconnect the reg/rect. from the stator(battery only lasts so long though) I have a good running 06 so I swapped reg/rect. and nothing. Then I swapped the CDI, then stator, then ign. coil and nothing. The spark seems poor and intermittant. Where do I go from here????? I love these bikes and want to fix this myself. I think from what I have found to eliminate valves, carb, air, fuel, safety switches, most areas that could have a short circuit since disconnecting the stator gets the bike to fire right up and I have swapped so many things from a known good running bike. I am getting vary discouraged:banghead:
  13. ghetto rider

    13/53 sprockets

    I run 14/48 and that works great for me. The stock rear chain gaurd looks to me like I shouldn't go larger than 48 or the chain would run too tight through it. Havn't tried any larger though.
  14. ghetto rider

    Bike ran great two days ago, now won't run

    Hey Bikeshopdude, your awesome! I followed your instructions and had SUCCESS! I just knew it had to be something simple. There wasn't any water in the tank or carb, just flooded. I'm going out for a much needed ride. Thank You!!!!!!!!!!! Oh yeah, just to add to this post, a few months ago I had the bike apart and put it back together and it wouldn't start. My fuel was low but still a little above the run filter but not much. I filled it up anyway and it started up. I am not sure, but it seemed as if the extra fuel put enough pressure to help prime the fuel system since it had been apart. Is this in any way accurate?
  15. ghetto rider

    Bike ran great two days ago, now won't run

    I couldn't find my feeler gauges so I am going to buy a new set. The petcock was not left on prime and the oil smells only of oil, and only has around 500 miles of use. It has been hot around here lately and I am just aching to get riding again. Withdrawl syndrome is kicking in.......
×