Jump to content

Search the Community

Showing results for tags '350s'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Dirt Bikes
    • General Dirt Bike Forums
    • Make / Model Specific
    • Dirt Bike Technical Forums
    • Special Interest Forums
    • Dirt Bike Regional Discussion
  • General
    • General Forums
  • ATV/UTV
    • General ATV/UTV Forums
    • Make/Model Specific
    • ATV/UTV Technical Forums
    • Special Interest Forums
    • ATV/UTV Regional Discussion
  • Inside TT
    • Inside TT Forums
  • ThumperTalk Clubs FAQ & Help's FAQ/Help & Discussion
  • RokFox's Current Kit
  • LCV Trail Riders's Local Information
  • LCV Trail Riders's Planning
  • Long Island Dirt & Moto X-Change's Trail Riding
  • Long Island Dirt & Moto X-Change's Enduro Racing
  • Long Island Dirt & Moto X-Change's Motocross Racing
  • Long Island Dirt & Moto X-Change's Harescramble Racing
  • Long Island Dirt & Moto X-Change's Dual Sport
  • Sonoma County,Mendocino County,Lake County & Napa County 707 Trail riders's tell us about your self and about your bike, what type of ridding you like to do,
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Discussion
  • Jersey MX and offroad's Places you ride
  • Sonoma Coast Skinny Twisties's Discussion

Categories

  • Universal Parts & Accessories
  • Parts & Acc. - Japanese Bikes
    • Honda Parts & Accessories
    • Kawasaki Parts & Accessories
    • Suzuki Parts & Accessories
    • Yamaha Parts & Accessories
  • Parts & Acc. - Euro Bikes
    • Beta Parts & Accessories
    • Husqvarna Parts & Accessories
    • KTM Parts & Accessories
    • Other Euro Parts & Accessories
  • Motorcycles
    • Off-Road Motorcycles
    • Dual Sport Motorcycles
    • Street Motorcycles
  • Powersports Gear & Apparel
  • Trucks, Trailers & Toy Haulers

Products Categories

Vehicles Categories

Garages

Blogs

There are no results to display.

There are no results to display.

Calendars

  • ThumperTalk Clubs FAQ & Help's Club Calendar
  • RokFox's Enduro Ride Schedule
  • LCV Trail Riders's Ride Calendar
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Club Calendar
  • Sonoma Coast Skinny Twisties's Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests

Found 1 result

  1. Highlander01

    1994 DR350SE starting issues

    Hi All, After searching and digging up info on this site for a while now, it's finally time to ask a question. First, I want to thank everyone for all the information I've found on here. It's been a huge help in bringing the DR back to life. As the title says, I have 1994 Suzuki DR350SE (electric start) that is having some starting troubles. It's actually my roommate's bike and it's been sitting for at least a year. He agreed to pay for all the parts and to let me ride it if I got it working (he's gone every summer and fall), so I read through the FSM and started with the basics. First thing I did was replace the battery and luckily it fired right up. After that, I put fresh fuel in the tank, swapped out the old cracked fuel lines for new ones, Adjusted the chain tension, changed the spark plug, changed the oil / oil filter, cleaned the bike up, and went out for a ride. It ran great accept for a lot of popping on deceleration when in gear, but after I got the bike good and hot and shut it off, it wouldn't start again (just kept cranking). I let it sit overnight and it fired up first try the next day. I took it for another long ride, turned it off and then tried to start it again. It fired up a second time, so I went out for another rip around town, came home, turned it off, and no dice. Since that day, I've taken the carb apart (which was way cleaner than expected), checked the jets, checked the float needle, etc, and gave it a quick clean. I put the carb back in and went to start it and it cranked but didn't turn over, so I pulled the plug and checked for spark. Nothing.. Broke out the multimeter and checked resistance on the ignition coil, pickup coil, and source coil. All were within the specs in the FSM. I cleaned the electric connectors which all looked a little dirty, but okay. I also checked the kill switches for the clutch and kick stand, thinking that one would be the culprit, but it appears that both have been removed and bypassed by the previous owner. At the end of a day of troubleshooting, I put everything back together and found a hill to try a bumpstart. It bumped on the second try and I went around for a quick ride. Came home, turned it off, and it wouldn't start. As it did the last few times, it would crank and crank and crank and not fire up. Battery still reads high 12v, plug doesn't appear to be wet, and the float bowl has plenty of fuel in it. I'm sure i'm missing something, but the only other thing I can think of that's left is the CDI unit... I've read that the ignition coil can be bad even though it's within spec, but it was replaced about a year ago. Thanks in advance for any suggestions. Looking forward to getting this thing back on the road!
×