Jump to content

Search the Community

Showing results for tags 'Stator'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Dirt Bikes
    • General Dirt Bike Forums
    • Make / Model Specific
    • Dirt Bike Technical Forums
    • Special Interest Forums
    • Dirt Bike Regional Discussion
  • General
    • General Forums
  • ATV / UTV
    • General ATV / UTV Forums
    • Make/Model Specific
    • ATV / UTV Regional Discussion
  • Inside TT
    • Advertise
    • Community Sponsors
    • Site Usage & Functions
    • Bug Reports & Suggestions
  • ThumperTalk Clubs FAQ & Help's FAQ/Help & Discussion
  • Chadwick, Missouri: Information & Riding's Topics
  • So Cal Flattrack's Club Forum
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Discussion
  • Jersey MX and offroad's Places you ride
  • Jersey MX and offroad's Discussion
  • SE Ohio Riders's Club Discussion
  • NorCal Trail Riders's Topics
  • NV Desert Exploration's Discussion
  • North Texas Enduro Riders's Topics
  • Twistin it in PHX's Introduce yourself!
  • Twistin it in PHX's Discussion
  • So-Cal Track and Trail's 1st club ride coming soon...
  • Moto TnT Track & Trail's Moto Tnt Racing Questions
  • Moto TnT Track & Trail's Rider's Forum
  • Dualspot Riders Orange County So~CaL's Club Discussion
  • Niagara region's Club Discussion
  • Sacramento Area Trail Riders's Club Discussion
  • NC wood riders.'s Club Discussion
  • Colorado US Route 50 Rides's Club Discussion
  • Middle GA Off-Road & Trails's Club Discussion

Categories

  • Powersports Gear & Apparel
  • Universal Parts & Accessories
  • Parts & Acc. - Japanese Bikes
    • Honda Parts & Accessories
    • Kawasaki Parts & Accessories
    • Suzuki Parts & Accessories
    • Yamaha Parts & Accessories
  • Parts & Acc. - Euro Bikes
    • Beta Parts & Accessories
    • Husqvarna Parts & Accessories
    • KTM Parts & Accessories
    • Other Euro Parts & Accessories
  • Motorcycles
    • Off-Road Motorcycles
    • Dual Sport Motorcycles
    • Street Motorcycles

Products Categories

Vehicles Categories

Garages

Blogs

There are no results to display.

There are no results to display.

Calendars

  • ThumperTalk Clubs FAQ & Help's Club Calendar
  • Chadwick, Missouri: Information & Riding's Events
  • So Cal Flattrack's Club Calendar
  • So Cal Flattrack's Events
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Club Calendar
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Events
  • SE Ohio Riders's Events Calendar
  • NorCal Trail Riders's Ride & Event calendar
  • NV Desert Exploration's Stuff that happens on a particular date
  • Central Washington riders's Events
  • Dualspot Riders Orange County So~CaL's Events Calendar
  • Niagara region's Club Events Calendar
  • Walker Valley Single Track Riders's I love Mondays trail ride
  • Sacramento Area Trail Riders's Events Calendar
  • NC wood riders.'s Club Calendar
  • Colorado US Route 50 Rides's Club Calendar
  • Middle GA Off-Road & Trails's Club Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests

Found 29 results

  1. Solomon Ralston

    SSR 125 Stator Trouble!

    Recently the chain on my ssr 125 popped off, broke the case, and got to a bracket that is part of the stator. Through the grey flywheel I can see six coils, but when I look up ssr125 stator replacements, it shows stators with two coils, so I’m confused as to what to buy. I was guessing that the a six coil stator like this- https://www.amazon.com/JCMOTO-Poles-Magneto-Stator-Motocross/dp/B01N3VWR1D would work and is a safer bet but I’m not sure. If you guys could leave links to static’s that’d help or tell me if this one would work-Thanks!
  2. mbennett95

    Streeting my 07 300XC

    Hey All, Just got my Tusk enduro lighting kit and realized it didn't include a battery. The 300XC doesn't come with battery, headlight, etc. So I figured I may just bite the bullet and draw stator power to run a battery for the kit. Fairly certain is pushes about 100W factory. I have an iridescant bulb headlight, and everything else is LED. Anyone have experience with this who could lend some advice or know if I'll need a regulator? Thanks. (Will keep post updated with pics)
  3. sledhead999

    HPI ignition

    Has anybody bought any ignition components from these guys? Stator, Flywheel, CDI, Coil, Voltage Regulator, etc? https://www.hpi.be/index.php If so, did you buy direct -or- from one of their dealers state side? Thinking about buying a fully programmable setup for my project bike.
  4. jaydawg27

    Choppy TT-R225, Need Help

    Hey I need some mechanical help from someone please. I have an old 2002 TT-R225 that I bought for my son to learn to ride on and ever since I bought it, well over a year ago it has never been right. When we first got it, it would ride choppy and the exhaust pipe would get cherry red, so I took it to a mechanic (friend of a friend) who cleaned out the carb and tuned it all up for me and stated it was in good working order. My buddy and I took it to the mountains and of course it didn't ride right. Lucky for us there was a mechanic up there who checked out the electrical and said the Stator was bad and needed to be replaced, so I took it back to the other mechanic and he replaced the stator and gave it a thumbs up. Went to ride it and surprise, surprise, it still wasn't right as it pops and sputters when you give it gas and didn't go more than 10 miles an hour. This time I took it to another mechanic who works on my other friends bike that he races hoping to get better results, like the first mechanic he took the carb apart and cleaned it out and replaced a few broken parts and jets. Gave it a thumbs up. Both he and my friend rode it and said it was good to go. I went and picked it up this weekend and to no surprise, when I rode it, it wasn't right. My friend was dumb founded. So here is the thing and my questions. If I am going down hill, or even on a straight away, it feels fine, but as soon as there is an incline or I give it too much gas it starts to sputter and pop and looses power. If I very very slowly give it gas it will get up to speed, but as soon as I give it too much or too fast it sputters, pops, and acts stupid. Also when I turn it off, it always shuts down with a loud pop out the exhaust. I am of the thought that this is no longer a carb issue but rather something else isn't tuned properly. With my limited knowledge it feels to me that the spark isn't hitting at the right time, or that the throttle is bad. Is it possible that when the Stator was replaced, it wasn't tuned or timed properly??? Anyone have any thoughts because at this point my wife wants me to just sell it, but I don't want to simply on principal now, LOL. Either my son is going to learn how to ride on this bike, or I am going to learn to work on motorcycle engines on this bike, but either way I dont see me selling it until I conquer what's wrong with it. Thanks.
  5. My bike has had problems when cold since I bought it a couple of months ago, but now runs fine for about five mins before it starts to splutter and won’t run above an idle- if I ride very slowly then it goes again but only for a short time. I have drained the tank, cleaned the carby and added some raw alcohol to fix any water in the tank but the problem is getting worse. The battery is not new but starts the bike without too much trouble- apparently a flat battery causes a similar problem to what I’m experiencing. I’m about to pull the flywheel cover off to inspect the stator but I have heard that the ignition key switch on Australian models can play up like a chook in a wombat hole- any ideas?
  6. Tyler Weakley

    2018 yz450f stator upgrade

    Good afternoon everyone, im looking to upgrade the stator in my 2018 yz450f to support a headlight, tail light, etc for a street legal supermoto build. I bought the bike used with the baja designs squadron pro light already installed, problem is, the stock stator is only 75W which dosent provide enough power to run the light for a long period of time, (the battery is drained instead of being charged and the headlight dims and flickers after 15 minutes of riding) my idea has been to replace the stock stator with the higher output stator from a 2018 yz450fx, im just wary of buying it because i have no clue if it will fit, and it could end up being $200+ down the drain, as far as i know both motors are the same with just a wider ratio in the transmission, but also the flywheel engine cover over the stator is different on the yz450fx than the yz450f, i assume for a heavier flywheel. Any input would be greatly appreciated.
  7. Why is it ok for ac stator to share chassis ground with dc/battery charging system in some cases? Im not sure if this is a 3 phase or single phase stator, or really anything about stators except the basic principles of electromagnetic conduction. My thought process is with AC stator 200 watts to chassis ground that it would maybe fry the battery from the dc ground to the negative terminal on the battery. And then a lower watt stock/oem stator would be not enough to worry about. Again i have no idea. Just wondering as i would like to wire my own bike and its super interesting. For me anyways. So Why is it ok in some cases for ac stator to share chassis ground with dc/battery charging system?
  8. Recently acquired an xr650r that was made into a super moto / dualsport and I’m noticing that the lights dim a lot at low rpms, nice and bright when it’s not idling. Is that normal? Once I was riding around trails at night in lower gears and it started to get very dim, I hopped back on the highway and it didn’t get brighter unless it was at like 7krpm. Turned it off and fired it back up and it was fine. Not sure what that means but it is concerning. Haven’t had that happen again tho, yet. So I was skeptical of this guy telling me it had a high output stator. I checked it tonight and it looks to be aftermarket, just have no idea what it is, and neither does the previous owner....(questionable) i feel like the bike only wants to idle at like 1700, any lower and the lights will get very dim, and sometimes the tachometer resets without the bike stalling cause the power supply gets so low when it’s idling at 1400. So so does anyone know what stator this is? I’m thinking electrosport?
  9. donkeydon

    Help, no spark 02 drz 400e

    Need help figuring out why my 02 drz doesn't have spark. Recently acquired this bike,ran great for a few weeks, then started up one day and began popping /no power on throttle. After cleaning carb and poking around a bit, I figured out it needed a new stator. Would run fine if I unplugged the regulator. Showed a short on ohm test. Installed a new stator from ricks electronics. Simple fix, right, but no, now I have no spark at all. Called ricks tech support and they told me to swap trigger coil wires, no change. All ohmmeter specs are fine, but l don't know how to check for voltage. Don't have a peak voltage adapter for my multimeter, any ideas out there? Thanks!
  10. Somebody please help me lol I have a 2009 ktm 300xcw the bike will start fine but wont idle the bike sounds like its hitting a rev limiter or blaaah blaaah blaaah every time I get on the throttle I've tried everything I could think of I've bought new reeds, cleaned all the jets out, changed the powervalve spring, changed the plug, still nothing I'm going to check the stator and coil tomorrow but I'm lost if it's not the stator or coul
  11. Hey guys, im looking for some electrical wisdom diagnosing my KLX 250 charging issue. Some background on the situation, the guy who had it before me ran the bike with a flat battery for some time. The bike has 8000 kms on it. He said the bike kills batteries so I figured it was a stator issue. I bought a fresh battery and gave it a full charge reading 12.6V at rest, at idle the battery dips down to 12.3V and slowly goes down over time. I think it should be around 13.5 at idle right? I disconnected the wiring harness where the stator meets the rectifier and tested the resistance on all 3 yellow wires leading to the stator and they all read the same .9 ohms so that seemed right. I pulled the cover and the wiring looks all normal, nothing looks burnt out. Next i went to test the rectifier forward bias ( negative lead on the multi on the positive lead to the rectifier and got 0 resistance on forward and 0 continunity on the reverse bias on the positive side? Does it seem safe to assume the regulator / rectifier is toasted? Any input is greatly appreciated and welcomed so I dont waste time and $$$ buying parts Rock on
  12. iTGbuDeeV

    250xc died while riding

    This past weekend I tried to participate in my first ever JDay Sprint enduro. I had just started lap 3 of 9 when the bike died on me. Seconds before it happened I thought I felt some friction, something under me rubbing. At first I thought it was just sand in the chain/sprocket (very deep sandy track). Then suddenly I went to give it throttle and it bogged. Off the throttle, sort of recovered, give throttle and bog again, off throttle and it puttered out. Pulled the plug, zero spark when kicking over. New plug, still no spark. Checked plug wire, coil, cdi (which is new) connections, grounds, kill switch etc, everything looks good. I THINK the stator gave up the ghost. I think the bolt may have backed out enough to cause it to wobble and make contact? Possibly shorting everything out? Would this cause a full dead spark? Am I way off? How much probably fried if this happened? I'm new to dirt bikes, any direction or info would be helpful.
  13. Hey everyone, So i bought a new lithium ion battery for my 2006 suzuki drz400s a few months ago. Bike has been running great, then one day i go for a ride in my local mountains, i get home and turn the bike off. Next day, bike wont turn over. It runs fine if i roll start or jump start it, but it wont hold any charge even after an hour of riding it in attempt to charge it. Could this be the stator? This is the second time ive had a relatively new battery go out on this bike. This battery was only a few months old. The first time it happened the batter was maybe a year old. Also, here are a few details that might be relevant. -i had the taillights connectors rewired by a local shop a while back, and one of the connections is faulty. I tested it and know for sure that the wiring for one of the taillights is no good. If im remembering right, the battery issue started after i had the shop do the lights. Could there be some kind of voltage leak happening here causing my battery to die? The reason im skeptical about it is because the battery was totally fine for a few months and the overnight the battery was dead. Any answers would be amazing. Thanks ya'll
  14. Dorgzz

    Flywheel rotor issue

    I have a 2003 WR450F which I bought a weeks ago knowing it was not running right. It gets to about half throttle when riding and can't give anymore power out, it just hesitates giving random burst of power. I have done the shims, carb jetting and new plug. Thought I'd look at the stator and discovered the following(see attached pictures) now I'm not very technical, but I am trying to buy a new housing(bowl that is magnetic that the stator fits into as pictured) I cannot seem to find any in the UK online. Is there a company that any UK riders use for this specific part? Any help with this and solving the problems would be appreciated.
  15. Levi Enns

    Fixing electric to kick

    I have a 2013 Husqvarna txc 310 and pretty much what happened is that the starter blew a screw out of its hole and cracked the side of the engine case. Fixing and putting on a new starter is going to cost alot and be alot of labour so can I just close off where the e start goes and just use the kickstart, I'm guessing there bikes would have a model that doesn't have an etart so I'm wondering if I can convert it to that. Maybe a stupid question idk.
  16. Steve Leddington

    1991Rmx stator

    Hi I am restoring a 1991 Rmx 250 and am looking for information regarding the stator I have the original stator but it looks like the pickup coil is not sitting in side the the crankcase,I need to order a replacement so would like to make sure it's the correct one before spending lots of money,Suzuki list just one stator for years through to 1998,but I am struggling to see how the mag cover will fit (I don't have a cover at the moment) thanks in advance for any help
  17. I've been having a problem with my 01 cr 125r, where it runs but doesn't run right, what I mean by that is it sputters and backfires and doesn't rev out every time. I had a shop try to fix it they went through everything but the electrical, I was wondering how to remove the stator assembly off of my bike, do I need to split the cases to get the not loose off of the main coil area? Or can I remove it without splitting cases? Thanks for the help.
  18. Hey guys, hoping someone out there is able to help me. I have a 2005 wr450f that I am overhauling/motarding. I'm planning on running a full D/C circuit and will be fully re-wiring the bike and loom myself. I purchased a Baja Designs Regulator/Rectifier and have completed their stator mod successfully. My only question is there is a wire that runs straight off the white stator wire that goes directly into the CDI unit as a red/white wire after the plug. What does this do? Does it need to stay as A/C? Will joining the 2 stator circuits with the Baja Designs upgrade mean there is too much A/C current running into the CDI if I leave it before the regulator/rectifier? Will add the wiring diagram with the wire highlighted later tonight when I get home. Thanks in advance, Dave
  19. Stewartlil

    STATOR HELP

    Does anyone have the ohm readings for a stator on a 2006 Yz450f written down! I would greatly appreciate that! I just got the zipty modded carb back, new gytr weighted flywheel, timing chain, valves shimmed, billet got start nit, and a lot of other goodies put on the bike. Before it would run with a roll start as carb was clogged? But once started as long as it was kept revving it would pull you off the seat. Now the spark plug has no spark and I can’t for the life of me find the ohm readings for a static test on the stator. Which wires ohm together and what should they read? Please help
  20. Brandon Gregory

    1993 yz 125 weak spark

    Hello everyone, I have a 1993 YZ 125 and I am having some problems with it. Bike runs good, except that it won't kick start and it won't idle at low RPM, but it will bump start and I idle when I keep it revved up. It is not jetting as my jets are clean. I've concluded that it has come down two week Spark. When I check for Spark by grounding the spark plug and kicking it over, it only Sparks when I kick really hard, and even that spark is not great. It has a brand new top and bottom end, including crank bearings and seals. It was running the same as it is now before it was rebuilt. I replace the ignition coil, spark plug, and kill switch. I think that it's either the stator or the flywheel, most likely the stator, but I would like some advice before I would buy another part because they're pricey. Thanks for your help in advance.
  21. Rodrigo Borges

    flywheel Messed things up!

    Hey guy, I’m sure you guys hear this a lot, but today I was riding and the engine suddenly stopped, so I open her up and bingo! Flywheel bolts fell off and destroyed the stator leaving a mess behind, anyways, all good! Bought all the new stuff I needed to fix it, and when I started to work on it the flywheel puller 38mm x 1.5 didn’t fit my flywheel. I have a 2000 DRZ400E, anyone know what’s going on? How can I tackle that? NEW HERE SO I ASK PLEASE BE NICE?
  22. New guy here, I have a 28,000km 2005 DRZ400SM with the 3x3 mod and Athena Big Bore kit that ran for a couple months and started every time. While riding the engine stopped and wouldn't start again. Mechanic took it apart and found the stator was burned to hell because flywheel bolts were loose (loctite could have prevented this from previous owner or factory). So we replaced the stator but still wouldn't start. While trying to fix the no-start issue we cleaned the valves, replaced piston, replaced regulator, cleaned the carb, installed JD Jet Kit and still no start. The battery is running at 13v and lights, horn and blinkers all work and its trying to crank but will not start... So I took it into another mechanic and they said the starter is running in reverse. I asked them if the polarity was backwards and they still don't know why it's doing that. This is preventing a spark from the plug (which was working fine before the stator issue). Any ideas from the forums would be super helpful... I've put 1k+ into parts and service so far and I'm kind of done... Thanks guys,
  23. Jeffery Stover

    Stator screws

    I have a 1994 rm 125 and my stator went out. I got the old stator out but in the process I stripped out the 2 Phillips head bolts and had to use channel locks to spin them out. I need to know what size the bolts are so I can replace them. I have looked at 3 different websites with the magneto diagram and it doesn't tell you the sizes or thread pitch. Can anyone help me? And could I put a normal 8mm bolt in it instead?
  24. GarrettRot

    95 Rm 125 stator burning out

    I have an 1995 RM 125 that keeps burning out stators. I bought it from a friend(who i trust) and he said it ran. It came with 2 stators, one was an electrosport, and the other I'm not sure. I did a top end and it fired up just fine(with the electrosport stator) i broke in the rebuild, but later when i rode it a little harder, it lost all power. Figuring it lost spark, i checked electrical connections, one looked iffy, so i patched it.( not exactly sure what one it was) later, after it cooled down, i rode it again. But after a while, the same thing happened, lost power. I removed the stator cover, and it stunk super bad. I'm a big noob with bikes so, figuring it had just burnt out, i hauled off and bought a new one( another electrosport for $80) and used that(without looking deeper). It had a hard time fitting into the bike, but i managed. This stator lasted 5 minutes before toasting. This time i actually looked at the stator, which showed signs of the flywheel/rotor rubbing on it, as well as the old one. Annoyed, i decided to try the other stator, which seemed a little smaller, and fit way better. But this time, after calmly riding it for 5m, i put it away. When i tried starting it again later, nothing, no spark. Apparently it burnt out as well. The flywheel doesn't move around at all, doesn't feel loose, and the stators seem to be in the correct spot, so why are my stators burning out? Sorry for the crappy post, ive never posted to forums before. There doesn't seem to be anything about my issue anywhere online. Any help appreciated, ask for pictures
  25. GarrettRot

    95 rm 125 stator burning out

    I have an 1995 RM 125 that keeps burning out stators. I bought it from a friend(who i trust) and he said it ran. It came with 2 stators, one was an electrosport, and the other I'm not sure. I did a top end and it fired up just fine(with the electrosport stator) i broke in the rebuild, but later when i rode it a little harder, it lost all power. Figuring it lost spark, i checked electrical connections, one looked iffy, so i patched it.( not exactly sure what one it was) later, after it cooled down, i rode it again. But after a while, the same thing happened, lost power. I removed the stator cover, and it stunk super bad. I'm a big noob with bikes so, figuring it had just burnt out, i hauled off and bought a new one( another electrosport for $80) and used that(without looking deeper). It had a hard time fitting into the bike, but i managed. This stator lasted 5 minutes before toasting. This time i actually looked at the stator, which showed signs of the flywheel/rotor rubbing on it, as well as the old one. Annoyed, i decided to try the other stator, which seemed a little smaller, and fit way better. But this time, after calmly riding it for 5m, i put it away. When i tried starting it again later, nothing, no spark. Apparently it burnt out as well. The flywheel doesn't move around at all, doesn't feel loose, and the stators seem to be in the correct spot, so why are my stators burning out? Sorry for the crappy post, ive never posted to forums before. There doesn't seem to be anything about my issue anywhere online. Any help appreciated, ask for pictures
×