Jump to content

Search the Community

Showing results for tags 'fuse'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Dirt Bikes
    • General Dirt Bike Forums
    • Make / Model Specific
    • Dirt Bike Technical Forums
    • Special Interest Forums
    • Dirt Bike Regional Discussion
  • General
    • General Forums
  • ATV / UTV
    • General ATV / UTV Forums
    • Make/Model Specific
    • ATV / UTV Regional Discussion
  • Inside TT
    • Advertise
    • Community Sponsors
    • Site Usage & Functions
    • Bug Reports & Suggestions
  • ThumperTalk Clubs FAQ & Help's FAQ/Help & Discussion
  • Chadwick, Missouri: Information & Riding's Topics
  • So Cal Flattrack's Club Forum
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Discussion
  • Jersey MX and offroad's Places you ride
  • Jersey MX and offroad's Discussion
  • The official Aussie 2 Stroke club's Favourite riding places
  • Folsom Trail Riders's Topics
  • NV Desert Exploration's Discussion

Categories

  • Powersports Gear & Apparel
  • Universal Parts & Accessories
  • Parts & Acc. - Japanese Bikes
    • Honda Parts & Accessories
    • Kawasaki Parts & Accessories
    • Suzuki Parts & Accessories
    • Yamaha Parts & Accessories
  • Parts & Acc. - Euro Bikes
    • Beta Parts & Accessories
    • Husqvarna Parts & Accessories
    • KTM Parts & Accessories
    • Other Euro Parts & Accessories
  • Motorcycles
    • Off-Road Motorcycles
    • Dual Sport Motorcycles
    • Street Motorcycles

Products Categories

Vehicles Categories

Garages

Blogs

There are no results to display.

There are no results to display.

Calendars

  • ThumperTalk Clubs FAQ & Help's Club Calendar
  • Chadwick, Missouri: Information & Riding's Events
  • So Cal Flattrack's Club Calendar
  • So Cal Flattrack's Events
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Club Calendar
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Events
  • Folsom Trail Riders's Ride & Event calendar
  • NV Desert Exploration's Stuff that happens on a particular date

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests

Found 3 results

  1. Hey guys, I recently dumped my KTM 690 in a rather large mud puddle. After washing it A LOT, and cleaning out the wires/battery under the seat I have found a new problem, it won't start as it should. It starts occasionally but most of the time there is a "buzzing" or "squealing" sound coming from what seems to be the fuse box when the starter is engaged. Has anyone else had this problem? Everything else seems to be running properly, though I have heard the buzzing noise most of the internet seem to attribute to the "fuel pump" priming, it sounds more like a solenoid to me but I'm not well versed in electronics. Any help would be appreciated, thanks in advance. The youtube link shows the starting issue
  2. Im having a strange problem and need some help. I have a 2016 ktm xc-f 350 that keeps blowing the 10 amp starter relay fuse. About a month ago i was riding, I stopped and turned the bike off, went to restart it and got absolutely nothing. I bump started it and rode it back to the truck (bike ran just fine). Blown starter relay fuse. The bike starts up just fine with a new fuse. I figured out it only blows just about when I hit my rev limiter. I tried a new voltage regulator and it still did it, although my old voltage regualtor isnt charging the battery very well, so its probably going out. Now the weird part. I was going to take it in to the shop, so i took out my shorai battery so they wouldnt get picky about the warranty, and put the old lithium ion battery back in (battery had sit about 3 months so it wasnt 100%.). After i put it in, the bike had no issues. Stopped blowing fuses. I even swapped the batteries around twice to double check and it was the battery. After that i sent the shorai battery in and waited a week to hear what they had to say. In the meantime i went riding. All was well for over an hour, then i went to restart the bike at one point: nothing. Blowing the starter relay fuse again. I can put one in and it will blow right about when i hit the rev limiter just like before. I just heard from shorai yesterday and their battery tested out good, no issues, like a new battery. I have no lights or anything and have checked for shorts but cant find anything. The only thing ive done to the bike is 52 tooth sprocket and a throttle tamer. What the hell is going on. I will take it in if i need to but figured i would try this out first. Thanks!
  3. I have a 2008 KTM EXC that had an aftermarket radiator fan installed by the previous owner and worked fine up until some heavy trail riding a while back. Im pretty bad with electrical stuff and havnt even owned a bike with an electric start until now. Ive heard having a fan on these is pretty much a necessity so Im trying to get it working. Ive heard I can test if the fan will work by touching two wires together but I dont know which ones. Also how can I check to see if its a fuse or something else? Thanks!
×