Jump to content

Search the Community

Showing results for tags 'technical'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Dirt Bikes
    • General Dirt Bike Forums
    • Make / Model Specific
    • Dirt Bike Technical Forums
    • Special Interest Forums
    • Dirt Bike Regional Discussion
  • General
    • General Forums
  • ATV / UTV
    • General ATV / UTV Forums
    • Make/Model Specific
    • ATV / UTV Regional Discussion
  • Inside TT
    • Advertise
    • Community Sponsors
    • Site Usage & Functions
    • Bug Reports & Suggestions
  • ThumperTalk Clubs FAQ & Help's FAQ/Help & Discussion
  • Chadwick, Missouri: Information & Riding's Topics
  • So Cal Flattrack's Club Forum
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Discussion
  • Jersey MX and offroad's Places you ride
  • Jersey MX and offroad's Discussion
  • The official Aussie 2 Stroke club's Favourite riding places
  • Folsom Trail Riders's Topics
  • NV Desert Exploration's Discussion

Categories

  • Universal Parts & Accessories
  • Parts & Acc. - Japanese Bikes
    • Honda Parts & Accessories
    • Kawasaki Parts & Accessories
    • Suzuki Parts & Accessories
    • Yamaha Parts & Accessories
  • Parts & Acc. - Euro Bikes
    • Beta Parts & Accessories
    • Husqvarna Parts & Accessories
    • KTM Parts & Accessories
    • Other Euro Parts & Accessories
  • Motorcycles
    • Off-Road Motorcycles
    • Dual Sport Motorcycles
    • Street Motorcycles
  • Powersports Gear & Apparel

Products Categories

Vehicles Categories

Garages

Blogs

There are no results to display.

There are no results to display.

Calendars

  • ThumperTalk Clubs FAQ & Help's Club Calendar
  • Chadwick, Missouri: Information & Riding's Events
  • So Cal Flattrack's Club Calendar
  • So Cal Flattrack's Events
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Club Calendar
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Events
  • Folsom Trail Riders's Ride & Event calendar
  • NV Desert Exploration's Stuff that happens on a particular date

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests

Found 6 results

  1. I have the dirt bike ramp, that you put in the hitch and lock it. Been using it for a little bit, and didn’t realize it but it looks liken someone hit the screw, the piece connected to the screw won’t unscrew as the screw blocks it. Now I can’t take it out. I’ve tried straightening out the screw with the mallet but couldn’t do it. Any advice?
  2. I recently broke my kill switch on my Honda Crf50 Pitbike. A replacement is on it's way, and I'd rather fix it myself than pay $48.00 of labor... (rip off). Does anyone know how to properly connect the new kill switch? Is the connecting piece behind the front number plate, or do I have to take off the gas tank and seat to wire to the CDI? Thanks in advance. ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------ **(I was going to upload some pictures so you know what I'm working with, but I can't seem to download the pictures. I'll upload them if I can figure it out.)**
  3. I just bought a 2002 Honda XR200 that was hardly ridden at all and has lived most of its life in a storage locker. I already cleaned the carburetor and replaced some of the jets. I also replaced the air filter. I have checked to make sure the pep cock is clean, and even replaced the gasket that goes between the exhaust pipe and the engine. It starts up on the first kick, but when I turn the throttle more than 1/4 the way, it dies. Any ideas that you have would be appreciated. Thank you.
  4. Thanks for taking a look. I hope someone can point me in the right direction to get this headache solved. I'll try and be as detailed as I can without bombarding you all with a wall text.. My bike is a 2005 DRZ400S with over 20,000 miles on it (mostly highway but lately more dirt). I just recently brought the bike in (after a good 3 hour ride in the mountains) to a local motorcycle service shop (Cycletune in Portland, OR). They did a list of maintenance work as well as replaced the tires, relocated my ignition switch, removed side stand switch, etc. I took the bike back home and it died after about 15 minutes on the highway. Now, my bike is experiencing intermittent loss of power, backfiring, stalling, etc. The mechanics working on my bike threw up their hands and told me they tried and couldn't figure it out. They said they did not believe that they caused the problem and did not know what was causing it. They said that they could "start throwing parts at it" and charge me hourly to try and figure it out... Before my bike died on the highway and was towed back to the shop, I got their "level 3 service" (highest service package available). This service included: Oil and filter change, Battery check, Wheel & tire inspection, Cooling system check,Inspect/clean air filter,Lube/adjust all cables and pivot points,Clean and adjust chain/belt,Inspect brake system,Check electrical system,Inspect clutch components (external),Fastener check,Set tire pressure,Safety check,Spark plug replacement,Carburetor/throttle body synchronization,Inspect/change transmission fluid/driveshaft fluid,Inspect steering head & wheel bearings,Cooling system check & flush if needed,Brake and Clutch,fluid flush. After they took my bike back in and couldn't fix the intermittent problem, they gave me a handwritten letter saying the following: "Level 3 service was perfored. All fluids changed. Valves checked (within specs) side stand switch eliminated. Bike had intermittent stalling problem and was towed back to shop. Problem was eventually replicated on test ride. Intermittent cutting out, loss of power. Eventual stalling was experienced. Fuel petcock was checked at the time of stalling - appeared okay. Correct level of fuel was found in float bowl at time of stalling. Pick up coil was replaced. New pick up coil did not solve problem. Intermittent problem still exists." Here's a sound clip of the problem (it starts around 0:14). Bike was warmed up for about 10 minutes before the audio was recorded. The bike idles just fine. Any ideas on what is causing this? I'm somewhat mechanically capable so I'm going to try and fix it myself (partly because I lost faith in the shop I went to for a variety of reasons and don't trust that they will fix it and partly because other local shops have a wait time of 4+ weeks to get my bike in). Thank you!
  5. So, i recently bought an ok condition TDX 125, and i'd need to know how often to change the oil. I don't have a service manual, and i cant find one online.
  6. Dylan Kilbride

    maintenance Yz85 03 running problems

    Hi, brand new to this forum so excuse me if this is in the wrong section! We got a 2002/03 (unsure), yz85 a couple of months ago. Very few issues at the start, ran perfect. In the past two months the bike has been very temperamental. It was idling very high when it started but alot of the time it wouldnt even start. Was making very throaty, burpy kind of noises, especially with a bit of a throttle twise to try and get it going. So, after pulling the carb to bits, cleaning all of the jets, itd run once well, then do the same thing again. We repeated this process 4/5 times to date. We eventually routed the cause to a frayed intake boot causing a vacuum leak. So we replaced it. Good as new. For the first run.. kicked like a horse the first time we ran it after replacing the boot. Then today, she's back to her old self. Started fine earlier, and then just went throaty and started to die. Sounded like the plug wasn't firing. So took it out, checked. Nothing, check if there was power to the coil pack, got a spark, so cleaned the plug with a wire brush (b10eg, btw) Away she goes again, for 2 minutes, and dies. Back to making throaty sounds again. The plug is working as of now. The bike would start if the throttle was wide open but be very very throaty, burpy and rough. Carb was cleaned earlier before this. (Today) That's all the detail I can give, any questions feel free to ask me. I've given up on it as I'm all out of ideas. There was a bit of black oily stuff leaking out of the exhaust as well, only noticed as I was finishing up. Any help, ideas, suggestions are welcomed. I have a video of it but can't upload here. Thanks in advance
×