Jump to content

Search the Community

Showing results for tags 'trailtechfan'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Dirt Bikes
    • General Dirt Bike Forums
    • Make / Model Specific
    • Dirt Bike Technical Forums
    • Special Interest Forums
    • Dirt Bike Regional Discussion
  • General
    • General Forums
  • ATV / UTV
    • General ATV / UTV Forums
    • Make/Model Specific
    • ATV / UTV Regional Discussion
  • Inside TT
    • Advertise
    • Community Sponsors
    • Site Usage & Functions
    • Bug Reports & Suggestions
  • ThumperTalk Clubs FAQ & Help's FAQ/Help & Discussion
  • Chadwick, Missouri: Information & Riding's Topics
  • So Cal Flattrack's Club Forum
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Discussion
  • Jersey MX and offroad's Places you ride
  • Jersey MX and offroad's Discussion
  • The official Aussie 2 Stroke club's Favourite riding places
  • Folsom Trail Riders's Topics
  • NV Desert Exploration's Discussion

Categories

  • Powersports Gear & Apparel
  • Universal Parts & Accessories
  • Parts & Acc. - Japanese Bikes
    • Honda Parts & Accessories
    • Kawasaki Parts & Accessories
    • Suzuki Parts & Accessories
    • Yamaha Parts & Accessories
  • Parts & Acc. - Euro Bikes
    • Beta Parts & Accessories
    • Husqvarna Parts & Accessories
    • KTM Parts & Accessories
    • Other Euro Parts & Accessories
  • Motorcycles
    • Off-Road Motorcycles
    • Dual Sport Motorcycles
    • Street Motorcycles

Products Categories

Vehicles Categories

Garages

Blogs

There are no results to display.

There are no results to display.

Calendars

  • ThumperTalk Clubs FAQ & Help's Club Calendar
  • Chadwick, Missouri: Information & Riding's Events
  • So Cal Flattrack's Club Calendar
  • So Cal Flattrack's Events
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Club Calendar
  • Thumperjunkies - Ottawa & Eastern Ontario Riders's Events
  • Folsom Trail Riders's Ride & Event calendar
  • NV Desert Exploration's Stuff that happens on a particular date

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests

Found 1 result

  1. Brady Brittain

    HELP 2012 Wr 450 getting hot FAST

    Here lately, probably the past month or so, my 2012 wr450 started running a lot hotter than usual. It happened right around the time I put some header wrap on my head pipe so I thought that was the issue and left it at that. Well I deliver for a company on my bike and its been warming up here in texas the past few weeks ~80's I decided to take the header wrap off because it felt unbearable riding with how hot this thing is now. So I take the wrap off and the bike still gets stupid hot stupid fast. Now when I say stupid hot I don't mean boiling but temps, but way higher than it used to in a shorter amount of time. Before this issue it could be 60 degrees or so outside and my trail tech fan would never kick on. Ever. The fan temp was set to trigger at 175. Now even when it is this cold out (60's) it can hit 175 in maybe a mile of easy riding. I ride on the street so it's constant air flow pretty much all of the time. The bike does have Engine Ice in it and it is full in the rad and appropriate amount in the reservoir. I started it this morning to see if the coolant was circulating with the cap off and the level would kind on bubble (probably not the right word for it) but it would kind of go up and down maybe a half inch or so every second or two. So I assume the pump is working as it should? Not sure but i've got a buddy who is bringing his stock water pump over and I am going to drain and clean my coolant system with white vinegar and water 50/50 to clean and flush all the junk, if there is any, out of the system and then try his pump setup. I checked my oil and it doesn't look milk shaked inside but I do plan on changing the oil tonight to see if there is anything going on in there which will tell me if impeller shaft seal is bad etc etc. Also, When it's in the garage and running my temps on my GYTR tuner says the engine temp is 150/160's when the trailtech fan kit is saying 180's but once the bike is off they seem to equalize out within 2 or so degrees from eachother. Not sure if that tells me anything but this is far all I know off the top of my head currently, If things change or I remember I will update the thread. The bike has 320 hrs on it probably 98% street riding as this is my daily driver. It is not losing coolant, leaking or burning. Valves are all in spec, checked last night (for the first time lmao) GYTR ECU and FMF powercore4 pipe Oil should be good but I am going to do it anyways tonight. Coolant getting flushed and cleaned along with a "new" water pump this evening aswell. If anyone has some tips or things to check for etc let me know. Thanks in advance!
×